CVE-2003-1365

Loading...

Général

Score :5.0/10.0
Sévérité :Moyenne
Catégorie :Erreur de validation d'entrée
Exploit :Disponible

Métriques d'impact

Confidentialité :Aucun
Intégrité :Partiel
Disponibilité :Aucun

Métriques d'exploitabilité

Vecteur d'Accès :Réseau
Complexité d'accès :Faible
Authentification :Aucune

Publiée le 31/12/03 - Mise à jour le 29/07/17

Description

The escape_dangerous_chars function in CGI::Lite 2.0 and earlier does not correctly remove special characters including (1) "\" (backslash), (2) "?", (3) "~" (tilde), (4) "^" (carat), (5) newline, or (6) carriage return, which could allow remote attackers to read or write arbitrary files, or execute arbitrary commands, in shell scripts that rely on CGI::Lite to filter such dangerous inputs.

Catégorie : Erreur de validation d'entrée

CWE-20 (Validation des entrées)
Le produit ne valide pas ou valide incorrectement les entrées, cela peut affecter le flux de contrôle ou le flux de données d'un programme.

Avis de sécurité

US National Vulnerability DatabaseCVE-2003-1365

Exploits

SecurityFocusBID-6833

Technologies associées

FournisseurProduit
perlcgi_lite

Partagez cette vulnérabilité avec :

Twitter Facebook LinkedIn Mail